2 Replies Latest reply on Jan 17, 2012 1:07 PM by jemmerling

    Latest Eclipse BPMN2 Plug-In does not seem to fully support jBPM5?

    jemmerling Newbie

      So far as I know, the Eclipse BPMN2 Plug-In discussed in Chapter 9 of the jBPM5.2 User's Guide does not fully support jBPM5 has been retired and replaced with a Plug-In that can be installed from the Eclipse site at http://download.eclipse.org/bpmn2-modeler/site/.

       

      I tried using this, and concluded that it does not fully support jBPM5. I can't go back and compare to the previous version (which was installable from the URL in Chapter 9 of the User's Guide) however this version does not seem fully compatible.

       

      Not being a jBPM5 guru or a BPMN2 guru, I will explain why I believe this.

       

      a.) Some diagrams created with the Drools plug-in (that is automatically installed when installing the jBPM5 demo) cannot be opened with this editor.

      b.) I a diagram can be opened, then it looks good in the editor, but if you try to look at what are called "variables" in the Drools editor, you see that they do not seem to be displayed properly. To give an example, if I want a process variable named "userId" and I define it using the Drools editor, then these two lines will be added to my *.bpmn file:

       

          

        <itemDefinition id="_userIdItem" structureRef="Object" /> <!-- first line item definition -->

        <process processType="Private" isExecutable="true" id="com.sample.bpmn" name="Sample Process" tns:packageName="defaultPackage" >

          <!-- process variables -->
          <property id="userId" itemSubjectRef="_userIdItem"/> <!-- second line property definition -->

       

           So try view these definition with the "new" plug-in (assuming you can open your diagram to start with) and if you have the same experience as me, what you see will not make sense to you.

       

      c.) Use the new plug-in to create a diagram. Then try to create item definitions and properties. There seems to be a way to create one or more item definitions, if you do, they will be created with some default id e.g. ItemDefinition_1, ItemDefinition_2, etc. and then it would be possible to rename these. Trying to define a process property, it lets you do that but doesn't seem to allow you to specify the "structureRef" attribute.

       

      So I guess my question(s) would be:

       

      Is this plug-in supposed to support jBPM5 at this time?

      If not, is there a plan for full jBPM5 support in future?

      Or is there a different approach to specifying a process that one should use (in light of the issues I have raised above) when using this plug-in with jBPM5?

       

      Thanks, I hope nobody has taken offense at this posting!

       

      --JE

        • 1. Re: Latest Eclipse BPMN2 Plug-In does not seem to fully support jBPM5?
          Jeff DeLong Master

          The old plugin, aka BPMN2 Process Editor, is not yet retired. Red Hat plans to support this editor when we provide support for jBPM 5.

           

          The new plugin, aka BPMN2 Visual Editor, is not yet fully baked. While the graphics look great, as you have discovered, many of the the element attributes are not suitable for jBPM 5 and not exposed in a way that would make sense to a user. This is a work in progress. Compared to a month ago, there are more attributes exposed than before. For example for Script Tasks there is a Script Language attribute and a Script attribute (though the Script Language attribute did not populate when downloading a process definition from the Web Designer). Process properties such as ID, Name, and Package Name are exposed and properly set, etc. And there is support for defining process Properties. But there are still a lot left to go.

           

          For now if you want to create an executable process definition then use either the old BPMN2 Process Editor or use the Web Designer. Hopefully the BPMN2 Visual Editor will be mature enough to use in another month or so.

          • 2. Re: Latest Eclipse BPMN2 Plug-In does not seem to fully support jBPM5?
            jemmerling Newbie

            Thanks!

             

            Somehow I had gotten the impression via another thread that the URL in Chapter 9 of the User's Guide no longer worked (I didn't bother to verify this on my own).

             

            If for some reason this URL is in fact no longer valid, what URL should I use to re-install the "BPMN2 Process Editor"? Thanks!

             

            --JE