5 Replies Latest reply on Oct 26, 2012 4:21 PM by ufkub

    3.3.2.SR1 Source Doesn't Build

    Robert Morse Apprentice

      I grabbed the source zip and attempted to build it. The build fails with the following error:

      /Users/rmorse/Downloads/richfaces-ui-3.3.2.SR1/framework/test/src/main/java/org/ajax4jsf/tests/EnumSupportExpressionFactoryWrapper.java:[32,7] org.ajax4jsf.tests.EnumSupportExpressionFactoryWrapper is not abstract and does not override abstract method coerceToType(java.lang.Object,java.lang.Class) in javax.el.ExpressionFactory
      
      /Users/rmorse/Downloads/richfaces-ui-3.3.2.SR1/framework/test/src/main/java/org/ajax4jsf/tests/EnumSupportExpressionFactoryWrapper.java:[45,1] method does not override or implement a method from a supertype
      
      /Users/rmorse/Downloads/richfaces-ui-3.3.2.SR1/framework/test/src/main/java/org/ajax4jsf/tests/EnumSupportExpressionFactoryWrapper.java:[73,1] method does not override or implement a method from a supertype
      
      /Users/rmorse/Downloads/richfaces-ui-3.3.2.SR1/framework/test/src/main/java/org/ajax4jsf/tests/EnumSupportExpressionFactoryWrapper.java:[83,1] method does not override or implement a method from a supertype
      
      /Users/rmorse/Downloads/richfaces-ui-3.3.2.SR1/framework/test/src/main/java/org/ajax4jsf/tests/EnumSupportExpressionFactoryWrapper.java:[92,1] method does not override or implement a method from a supertype
      
      


      I need to rebuild it because I'd like to try the latest TinyMCE editor control which is a couple of revisions more recent than that in 3.3.2.SR1. The current version is a bit flaky.