4 Replies Latest reply on Jan 19, 2012 8:27 AM by h_haaks

    virtual-server access-log pattern attribute not saved

    h_haaks Newbie

      I'd like to set up a custom log pattern for access logging in jboss7.

       

      I entered the following in standalone.xml:

       

      <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">

          <connector name="http" protocol="HTTP/1.1" socket-binding="http" scheme="http"/>

          <virtual-server name="default-host" enable-welcome-root="true">

              <alias name="localhost"/>

              <alias name="example.com"/>

                  <access-log pattern="&#37;h &#37;l &#37;u &#37;t &#37;T &#37;D &#34;&#37;r&#34; &#37;s &#37;b &#34;&#37;{Referer}i&#34; &#34;&#37;{User-Agent}i&#34;" />

          </virtual-server>

      </subsystem>

       

      This seems to work as it should, but when I look at standalone.xml after startup it is changed to:

       

      <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">

          <connector name="http" protocol="HTTP/1.1" socket-binding="http" scheme="http"/>

          <virtual-server name="default-host" enable-welcome-root="true">

              <alias name="localhost"/>

              <alias name="example.com"/>

              <access-log/>

          </virtual-server>

      </subsystem>

       

      How do I get my pattern to stay in my config?