1 Reply Latest reply on Jan 19, 2012 8:20 PM by nt2005

    a4j does not work for my maven Project!

    nt2005 Newbie

      Hey Guys,

       

      I got a problem with my web-app...

      I use eclipse indigo and created a mavenize Seam 2.2. Project.

       

      Here is my edited home.xhtml:

       

      <!DOCTYPE composition PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <ui:composition xmlns="http://www.w3.org/1999/xhtml"
          xmlns:s="http://jboss.com/products/seam/taglib"
          xmlns:h="http://java.sun.com/jsf/html"
          xmlns:f="http://java.sun.com/jsf/core"
          xmlns:ui="http://java.sun.com/jsf/facelets"
          xmlns:a4j="http://richfaces.org/a4j"
          xmlns:rich="http://richfaces.org/rich"
          xmlns:c="http://java.sun.com/jstl/core">
      
              <a4j:region>
                  <h:form>
                      <a4j:poll id="poll" interval="500" enabled="...." />
                  </h:form>
              </a4j:region>
      
              <h1>Welcome to Seam!</h1>
              <rich:panel>
                  <h:panelGrid columns="2">
                      <h:graphicImage value="/img/seamlogo.png" alt="Seam logo"/>
                          .....
                  </h:panelGrid>
              </rich:panel>
      
      </ui:composition>
      

       

      The problem is, that on my jboss as6 server the ajax-tags don´t get converted in browser. Tags like "<h..." work but nothing with "<a4j".

      Eclipse don´t show me any errors about it.

       

      Please, can anyone help me?