1 Reply Latest reply on Jan 20, 2012 11:18 AM by Michael Musgrove

    Error deploying MySQL as an XA datasource

    Michael Musgrove Master

      I tried deploying MySQL as an XA datasource  (I installed the driver as a core module).

       

      I get the following error when deploying a war that uses the datasource as a JPA persistence context:

       

      14:57:34,960 INFO  [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: /jboss-as-xa

      14:57:34,962 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.security.jacc."jboss-as-xa.war": org.jboss.msc.service.StartException in service jboss.security.jacc."jboss-as-xa.war": Failed to start service

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1780) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_29]

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_29]

          at java.lang.Thread.run(Thread.java:662) [:1.6.0_29]

      Caused by: java.lang.NoSuchFieldError: log

          at org.jboss.as.web.security.WarJaccService.createPermissions(WarJaccService.java:88)

          at org.jboss.as.web.security.WarJaccService.createPermissions(WarJaccService.java:57)

          at org.jboss.as.security.service.JaccService.start(JaccService.java:86)

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

          ... 3 more

      which is odd since./web/src/main/java/org/jboss/as/web/security/WarJaccService.java extends org/jboss/as/security/service/JaccService.java which defines the inaccessible field as protected.

       

      Any tips on how to make progress. I tried adding various security related module dependencies to the driver module file (but got the same problem).