5 Replies Latest reply on Nov 18, 2014 6:35 AM by Yuvraj Patel

    Jboss as7 org.apache.tomcat.util.http.Parameters.MAX_COUNT defaults to 512

    Danjel Nyberg Newbie

      Hi

       

      I have recently been upgrading to jboss as7.1.0cr1b

       

      and i have webforms that have more properties than the default (512)

      I downloaded the Parameters.java from a nightly build and saw that it defaults to 512 if not the System property

      org.apache.tomcat.util.http.Parameter.MAX_COUNT is set to something else.

       

      This seems like a good idea, but where is a good solution to override it?

       

      If i override it in my servlets init method it works as long as no webrequests are called before my servlet

      The Parameters.java only loads this value once in a protected static final int:

       

      public final class Parameter {

      ...

      ...

           protected static final int MAX_COUNT = Integer.valueOf(System.getProperty("org.apache.tomcat.util.http.Parameter.MAX_COUNT,"512)).intValue();

       

      So once the Parameter class is loaded the value can not be overwritten...

       

      I have tried to set this in the JAVA_OPTS in standalone, but this was ignored. I have also tried to set the value in my servlets init method

      this one worked, but only if no requests were made during startup of jboss, which is never the case in a production environment.

       

      Is there a way of setting this system variable properly or is the only solution to modify my forms to send much less data

       

      Best Regards

      /Danjel