5 Replies Latest reply on Feb 23, 2012 8:34 AM by shay1680

    Unable to deploy to AS7.1.0 CR1 using Maven




      I was trying to deploy my webapp to 7.1 using the maven via the JBoss AS plugin but i keep getting this error



      Jan 30, 2012 11:26:45 AM org.xnio.ChannelListeners invokeChannelListener
      ERROR: A channel event listener threw an exception
          at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:291)
          at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:182)
          at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:71)
          at org.xnio.channels.TranslatingSuspendableChannel.handleReadable(TranslatingSuspendableChannel.java:173)
          at org.xnio.channels.TranslatingSuspendableChannel$2.handleEvent(TranslatingSuspendableChannel.java:94)
          at org.xnio.channels.TranslatingSuspendableChannel$2.handleEvent(TranslatingSuspendableChannel.java:92)
          at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:71)
          at org.xnio.nio.NioHandle.invoke(NioHandle.java:77)
          at org.xnio.nio.AbstractNioChannelThread$1.run(AbstractNioChannelThread.java:142)
          at java.lang.Thread.run(Thread.java:662)


      and on the server output i see this



      11:26:50,927 ERROR [org.jboss.remoting.remote] (Remoting "server1:MANAGEMENT" read-1) JBREM000200: Remote connection failed: java.io.IOException: An existing connection was forcibly closed by the remote host


      My pom is set up like so




      This all worked fine under 7.0.2 Final but doesn't seem to work here.


      Any thoughts as to what i might be missing in order to get this to work.  It works fine if i drop the war in the deployment folder.  Haven't tried deploying form the console or to the domain but i think those would work as well.



        • 1. Re: Unable to deploy to AS7.1.0 CR1 using Maven

          I'd file a bugreport for JBREM, with steps to reproduce.

          • 2. Re: Unable to deploy to AS7.1.0 CR1 using Maven

            I ran into this also on 7.1 final , and filed a bug report https://issues.jboss.org/browse/JBASMP-22



            • 3. Re: Unable to deploy to AS7.1.0 CR1 using Maven

              I had the issue related to deploy with Maven in all the JBoss AS7.x versions.

              The latest version JBoss AS 7.1.0.Final has a corresponding maven plugin (i.e. 7.1.0.Final) so be sure to use a newer version, maybe there are some changes between the versions.


              This happens in my case:

              I start the JBoss with standalone.bat and usually the JBoss deployment mechanism (doesn't matter if the deploy is done with Maven or just copy the war archive in jboss-as-7.1.0.x\standalone\deployments) get stuck while deploying.

              As a workaround, when I see in the IDE console that the deployment hangs (or in JBoss admin console that the new archive does not appear in the deployments), I switch to the JBoss console and press Ctrl+Z to unlock the process and the deploy continues as it should.


              Besides the fact that the debug mode is very slow, many of the live updates performed by JRebel are not applied until I use the same strategy (press Ctrl+Z in JBoss console). I must admit that I had not enough time to check if JRebel is causing those issues but I doubt that it’s JRebel fault.

              • 4. Re: Unable to deploy to AS7.1.0 CR1 using Maven

                Your problem is that you are using plugin version 7.0.0 which wont work with 7.1.0 becouse of added security features.


                just upgrade plugin to the same version your app server is and it should work.




                • 5. Re: Unable to deploy to AS7.1.0 CR1 using Maven

                  Hi Tomaz,


                  upgrading to last version fixed the issue, thanks!


                  Bug closed


                  what was the new security feature that was added?