14 Replies Latest reply on Mar 22, 2012 5:13 AM by Muthukumaran Manickavasagam

    HornetQ Failover Issue

    Muthukumaran Manickavasagam Newbie

      HI,

       

      As of now i'm using "HornetQ_2_2_8_EAP_GA" in my environment as a standalone server

       

      I'm able to do clustering configuration having node 1 and 2 with static connector. But i'm trying to test the fail over configuration but i'm not able to start either live or backup server not even once.

       

      What i understood is that we need following configiuration in hornetq-configuration.xml for live server,

       

      <backup-connector-ref connector-name="backup-connector"/>

       

      <connectors>

           <!-- This connector specifies how to connect to the backup server    -->

           <connector name="backup-connector">

             <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory</factory-class>

             <param key="host" value="localhost"/>

             <param key="port" value="5445"/>

           </connector>

      </connectors>

       

      When i start the live server with this configuration, no matter what, the server always throwing me out with "SAXParser" exception as it is not able to recognize the "backup-connector-ref".

       

      On the other hand if i add the backup tag (<backup>true</backup>) in my backup server, the server is just hanging after the following message,

       

      * [main] 1-Feb 15:40:49,203 WARNING [FileConfigurationParser]  AIO wasn't located on this platform, it will fall back to using pure Java NIO. If your platform is Linux, install LibAIO to enable the AIO journal

      * [main] 1-Feb 15:40:49,297 INFO [HornetQServerImpl]  backup server is starting with configuration HornetQ Configuration (clustered=true,backup=true,sharedStore=false,journalDirectory=../data/journal,bindingsDirectory=../data/bindings,largeMessagesDirectory=../data/large-messages,pagingDir
      ectory=../data/paging)

       

      Do i miss anything basic?

       

      -- Muthu