4 Replies Latest reply on Mar 29, 2010 12:23 AM by Arbi Sookazian

    I'm screwed!

    Arbi Sookazian Master

      This is totally off topic but I'm in pain here guys.


      I have a dual boot Ubuntu 9.10 and Win7 box at home with personal docs/pix on Win7 partition.  This happened:


      http://www.linuxquestions.org/questions/linux-newbie-8/win7-and-dual-ubuntu-9.10-partitions-798105/#post3915120


      No recent backup.


      Please pray for me :(

        • 1. Re: I'm screwed!
          Stuart Douglas Master

          You deleted the partition that had grub on it. Your data should be fine.



          You have a few options. The easiest is probably to use a win7 disk to repair the mbr, you will not be able to boot into linux afterwards until you re-install grub. There should be plenty of tutorials around on this.


          You can also get a super grub disk and user it to repair your grub install, or boot windows from it. Off the top of my head the grub command to boot windows is something like:


          rootnoverify (hd0,3)
          chainloader +1
          


          • 2. Re: I'm screwed!
            Stuart Douglas Master

            That should have been:


            rootnoverify (hd0,3)
            chainloader +1
            boot
            

            • 3. Re: I'm screwed!
              Arbi Sookazian Master

              Stuart, thx for your responses.  I spent a few hrs on this to no avail.  I tried the Super GRUB Disk CD (0.9799) and it was not able to fix it.


              I also tried booting from a Win7 Ultimate DVD and I get:


              No boot device available
              SATA 0:Installed
              SATA 1:Installed
              SATA 2:None
              SATA 3:None



              I'm taking this to the Linux forums where it belongs.  Thx a lot and I owe you a beer!

              • 4. Re: I'm screwed!
                Arbi Sookazian Master
                Well, the Win7 Ultimate DVD wasn't booting properly (or it wasn't a boot dvd but I did see a boot directory in the root).

                "I am using Win7 now (and running Seagate backup!)  thx for your help but I think I have too many partitions installed now.  I installed Ubuntu twice, uninstalled once, ..., installed again and now GRUB loader seems to be functional (haven't tested Ubuntu yet!)"

                http://www.linuxquestions.org/questions/linux-newbie-8/win7-and-dual-ubuntu-9.10-partitions-798105

                I feel like I was attacked by sharks and now I've been rescued...  Damn what a PITA.  There's way too much to learn/know in the *nix world.

                FYI: after all this I noticed that my |Linux in a Nutshell O'Reilly| book covers LILO and GRUB in the Boot Methods chapter.  Hey as long as nobody is hurt (i.e. don't lose any data/files) and you learn something, maybe the pain is worth it?

                Backup in progress...

                Break it down!