I agree that the renames are a bad idea, I think creating multiple names will only cause confusion.
I think it would also be good to allow the user of the @TransactionAttribute annotation though, as there have been lots of forum posts where users have been confused with which annotations only work on EJB's and which ones work on all seam components.
Hmm, but that's all typesafe, so once you use the @TransactionAttribute annotation you know which type to use as the element. And creating two annotation elements for both enumerations may be even more confusing imho.
I recall commenting about this to the Seam dev team recently. Changing the names is a bad idea (e.g. ISOLATED instead of REQUIRES_NEW).
This is one of the reasons it would be nice if there was a
smart@TransAttributeType annotation that would allow the dev to select the appropriate enum constant for the appropriate context (i.e. in Java EE 5, REQUIRES_NEW is available for session bean but not available for Seam 2.x JavaBean component). That way you could use the same annotation for both EJB3 and JavaBeans and not worry about remembering which annotation to use for which kind of component. I have a feeling this is not technically possible with annotations.
So we're stuck with using Seam's @Transactional and EJB 3's @TransactionAttribute...
Yes, we shouldn't change the names of the attributes.