1 Reply Latest reply on May 9, 2011 12:17 PM by lholmquist

    Forge maven warning

    lholmquist Newbie

      I'm using forge,following the user guide on how to create a new project. i create a new project, add some scaffolding and persistence.  when i execute the build command everything compiles fine but i get some warnings just after the scanning for projects line:




      [testForge] testForge $ build
      [INFO] Scanning for projects...
      [WARNING]
      [WARNING] Some problems were encountered while building the effective model for
      com.test.forge:testForge:war:1.0.0-SNAPSHOT
      [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-comp
      iler-plugin is missing. @ line 26, column 15
      [WARNING]
      [WARNING] It is highly recommended to fix these problems because they threaten t
      he stability of your build.
      [WARNING]
      [WARNING] For this reason, future Maven versions might no longer support buildin
      g such malformed projects.
      [WARNING]



      i'm new to maven so i'm not sure what this is all about.  i'm using windows 7,  yea..  i know.


      I also tried to install the richfaces plugin,  and was able to do so but got this same warning when installing it.  but when i tried to add it to my project other errors happened.  probably related to these warnings.