1 Reply Latest reply on May 12, 2011 7:27 PM by Jason Porter

    Database using Forge

    nraf Newbie

      I'm trying to set up a new project created using Forge to communicate with a Postgresql database however I've been having some issues.


      When I set the database to POSTGRES, it ignores it when creating the persistence.xml file.


      The Forge output is: http://pastebin.com/YXqnbEmv


      The resulting persistence.xml file is as follows:



      <?xml version="1.0" encoding="UTF-8" standalone="no"?>
      
      <persistence xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="2.0">
      
        <persistence-unit name="forge-default" transaction-type="JTA">
      
          <description>Forge Persistence Unit</description>
      
          <provider>org.hibernate.ejb.HibernatePersistence</provider>
      
          <jta-data-source>java:/DefaultDS</jta-data-source>
      
          <exclude-unlisted-classes>false</exclude-unlisted-classes>
      
          <properties>
      
            <property name="hibernate.hbm2ddl.auto" value="create-drop"/>
      
            <property name="hibernate.show_sql" value="true"/>
      
            <property name="hibernate.format_sql" value="true"/>
      
            <property name="hibernate.transaction.flush_before_completion" value="true"/>
      
            <property name="hibernate.dialect" value="org.hibernate.dialect.HSQLDialect"/>
      
            <property name="openjpa.jdbc.DBDictionary" value="hsql"/>
      
          </properties>
      
        </persistence-unit>
      
      </persistence>