3 Replies Latest reply on Dec 24, 2009 5:06 PM by Arbi Sookazian

    Launching Jetty embedded from Eclipse regarding numberguess example

    Arbi Sookazian Master

      I followed these directions from readme.txt:



      Launching Jetty embedded from Eclipse

      First, set up the Eclipse environment:

      mvn clean eclipse:clean eclipse:eclipse -Pjetty-ide

      Next, put all the needed resources into the src/main/webapp

      mvn war:inplace -Pjetty-ide

      Now, you are ready to run the server in Eclipse; find the Start class in
      src/jetty/java, and run its main method as a Java Application. The server
      will launch. You can view the application at the following local URL:

      http://localhost:8080

      I am running Eclipse Galileo 3.5.1.  The instructions forgot to mention that you must create a M2_REPO variable to add to build path.


      The other problem is that I am unable to run the Start class due to Eclipse stating selection does not contain a main type which I assume is complaining that a public static void main() method does not exist in the class, which is not the case, it does exist.


      so why can't I run this class as a Java application from Eclipse?


      plz note that I am running jboss-6.0.0-SNAPSHOT but it worked fine with the exploded weld-numberguess.war that was deployed to server\default\deploy directory...