3 Replies Latest reply on Jan 30, 2010 8:16 PM by Pete Muir

    weld&glassfishv3 - failed to lazily initialize a collection of role

    Jeronimo Azevedo Newbie

      Hi,


      I am new to Weld and I tried the weld implemation which comes with the galssfish v3. It works fine for the few tests I did. I just have a question, I created an example where I have an entity which refers to a collection and the collection is lazy loaded (hibernet JPA provider). I have a jsf client to load the entity, teh entity loads and I can see on the webpage. When than I call from the jsf the lazy to load collection I always receive the 'layily load exception'. Well I tried every possible scope in weld, but I have always the same problem. I rad in the seam docs that Seam solves this problem. The question I have is, I have to use soem kind of 'open in session view' interceptor or I could use Seam?
      I want to do the follwing config Weld and Seam and EJB3.1 and Glassfishv3 do you think this would work?


      Thnaks and sorry for the stupid question but I am not sure about I rad... I just not a hint...