2 Replies Latest reply on Apr 4, 2011 9:19 AM by Fabricio Lemos

    ClassNotFoundException with exploded project

    Fabricio Lemos Newbie

      Hello,


      I´m getting ClassNotFoundException while deploying an exploded Weld project in Glassfish 3.1. The problem occurs with exploded war projects that contains an exploded jar project in WEB-INF/lib and beans.xml in WEB-INF/lib


      Here is the stacktrace:



      SEVERE: ectcore.jar.core.MyUtilityClass
      java.lang.ClassNotFoundException: ectcore.jar.core.MyUtilityClass
          at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1518)
          at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1368)
          at org.glassfish.weld.BeanDeploymentArchiveImpl.populate(BeanDeploymentArchiveImpl.java:340)
          at org.glassfish.weld.BeanDeploymentArchiveImpl.<init>(BeanDeploymentArchiveImpl.java:148)
          at org.glassfish.weld.BeanDeploymentArchiveImpl.<init>(BeanDeploymentArchiveImpl.java:128)
          at org.glassfish.weld.DeploymentImpl.<init>(DeploymentImpl.java:120)
          at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:334)
          at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:99)
          at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:186)
          at org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:249)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:460)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
          at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:370)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1067)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1247)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1235)
          at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:465)
          at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:222)
          at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
          at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
          at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
          at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:822)
          at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
          at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1013)
          at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
          at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
          at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
          at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
          at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
          at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
          at java.lang.Thread.run(Thread.java:619)



      The problem seems to be occurring with others too and makes a nightmare developing with weld + eclipse + glassfish 3.1


      I already ask for help in Glassfish forum (sorry to double post but I´m still looking for a solution) and was said that it is Weld-related.