0 Replies Latest reply on Aug 1, 2011 2:43 PM by George Vagenas

    Weld and Mobicents SipServlets integration - load-on-startup & arquillian issue issue

    George Vagenas Newbie

      Hi guys,


      I am working on a framework based on CDI for Mobicents Sip Servlets platform (http://www.mobicents.org/mss/ctf/mss-ctf.html) and i am having some issues that i would like to discuss. The integration is based on Weld 1.1.0.Final.


      So Weld bootstraps correct and all my beans, producer methods, events, etc,  are resolved and are available for use in a servlet or a bean class.


      The first issue i have is with http servlets when they don't define

      load-on-startup=1

      If in the application an http servlet that needs a field injection for example, doesn't have
      <load-on-startup>1</load-on-startup>

      defined, even though the injection point is discovered and resolved (verified with debugging), at runtime the field is null, similarly, methods with @Observes at parameters never get called. When the servlet defined with
      load-on-start-up=1

      injection and event mechanism is working correctly.


      I am also working on a Mobicents Sip Servlets container for Arquillian, and there the injections and methods with @Observes parameters are not working for servlets with no

      load-on-startup=1

      as before, but also for simple beans.
      A simple bean, that defines a field injection and one of the methods have (@Observe @Invite SipServletRequest req) for parameters, will never get injected with the bean or notified for the event, even though going through debugging i can see that injection point is discovered and resolved and the same for the observer method.


      Can you shed some lights over here about these issues? Which direction should i start looking at?


      Thanks
      George