6 Replies Latest reply on Feb 28, 2008 2:27 AM by Tony Herstell

    JBoss tools not working

    Tony Herstell Master

      As the Jboss Seam/RF tools are currently not able to be added to MyEclipse - something about having to be a single file for deployment:



      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=130496 

      I would like to try out JBoss Developer Studio to see if its suits my way of working.


      Does anyone know how to download a trial version?


        • 1. Re: JBoss tools not working
          James Kelly Newbie

          I tinkered around with JBoss Tools using these instructions. I installed a fresh copy of Eclipse Europa for J2EE developers and used the Eclipse link functionality to add the JBoss Tools plugins.


          I ran into an issue with getting Seam functionality enabled for an existing Java project, i.e. getting the Seam Components view to populate. Here's how I worked around it (there's some voodoo here since I didn't spend too much time evaluating the IDE)



          • downloaded the JBoss Tools nightly build,

          • set my Seam Runtime to my Seam home folder (an extracted copy of jboss-seam-2.0.0.GA),

          • removed and re-applied the Seam support to the project - basically unchecking, applying, and then rechecking the Seam Support.

          • set the JBoss Tools HTML Editor as the default editor for .xhtml files



          • 2. Re: JBoss tools not working
            Tony Herstell Master

            Most people probably know this.... but...



            I installed tool(s) by creating a directory:


            c:/MyEclipse Plugins


            and used
            Help->Software Updates-> Manage Configuration from within MyEclipse to access the extra tools config wizard...


            From this window click on Add External Location


            From here point this to
            c:/MyEclipse Plugins/eclipse


            and thats it


            (you can add in URLs for tools that provide them from Help->Software Updates-> Find and Install)


            This is very useful for adding ANY other plugins... as you can install a newer Eclipse (MyEclipse) and just point it at that folder each time...


            Anyhow.. The plugins didn't work with MyEclipse anyhow :(


            These tips may even work for free eclipse...


            Tony.

            • 3. Re: JBoss tools not working
              Tony Herstell Master

              I never got as far as setting teh seam runtime whatever that is!


              • 4. Re: JBoss tools not working
                James Kelly Newbie

                I might not have been clear, but AFAIK the JBoss Tools package is essentially the open source version of the JBoss Developer Studio.


                In other words, go here if you're looking for a trial version of the developer studio.

                • 5. Re: JBoss tools not working
                  Tony Herstell Master

                  I have tried to install these tool sinto MyEclipse which doesn't work.
                  Having to go back to Normal Eclipse is not something I am keen to do.


                  So I assumed that RedHat Developer actually had more to it thatn normal Eclipse.


                  I would rather stay with MyEclipse without JBoss tools than go back to normal eclipse.


                  Thanks for the info anyhow.

                  • 6. Re: JBoss tools not working
                    Tony Herstell Master

                    The MyEclipse peeps are having a meeting end of this week and they are looking into putting JBoss tool into the roadmap (i.e. more support for Seam) as a matter of urgency!
                    I have asked the Jboss Tools guys to strip out the stuff from the Tools that causes MyEclipse to barf (summat to do with needing a single deployable file - which hopefully just means dropping support for the deployer and SeamGen which I don't use anyhow).
                    We will see what happens.