5 Replies Latest reply on Mar 13, 2008 1:12 PM by Pete Muir

    JSF 1.1 supported in Seam 2.0.1GA?

    Rich Nill Newbie

      I've tried searching the Seam documentation and forums, but I didn't have success finding the answer to the above question.


      We want to use Seam 2.0.1GA with JSF 1.1, since some of the JSF component libraries we are planning to use (e.g. Tomahawk) only work on JSF 1.1.


      Is JSF 1.1 supported with Seam?  Are there specific JSF 1.1 implementations that we must use?


      Thanks in advance,
      Rich

        • 1. Re: JSF 1.1 supported in Seam 2.0.1GA?
          Pete Muir Master

          IMO you would be better off picking a component library that supports JSF 1.2 - well designed JSF 1.1 component libraries should work fine in JSF 1.2 with no modification.


          Specifically, no Seam 2 doesn't support JSF 1.2.

          • 2. Re: JSF 1.1 supported in Seam 2.0.1GA?
            Rich Nill Newbie

            Hi Pete,


            Thanks for the quick response.


            One clarification: Seam doesn't support JSF 1.2 or Seam doesn't require JSF 1.2? 


            To be honest, I don't know the significance of the difference between 1.1 and 1.2.  I'm guessing Seam will work either.  Correct?


            Thanks again.

            • 3. Re: JSF 1.1 supported in Seam 2.0.1GA?
              Keith Naas Novice

              Read the docs for an explicit statement about the use of Tomahawk.  If you really want to get the most of Seam and JSF, I would recommend using JSF1.2 and a component library that supports it OOTB.

              • 4. Re: JSF 1.1 supported in Seam 2.0.1GA?
                Rich Nill Newbie

                Thanks for the link - I missed that when browsing/searching the documentation.


                We have already made a decision to use ICEFaces, which supports both JSF 1.1 and JSF 1.2.  This decision was made several months ago prior to us considering Seam and isn't open to be changed in the short term.


                The reason we have been considering Tomahawk as well is due to the fact that ICEFaces can coexist with Tomahawk.  Our thought was that we it may fill a few gaps in the ICEFaces functionality, and/or some of our development teams may not have the need for the Ajax functionality.

                • 5. Re: JSF 1.1 supported in Seam 2.0.1GA?
                  Pete Muir Master

                  Rich Nill wrote on Mar 12, 2008 06:12 PM:


                  Hi Pete,

                  Thanks for the quick response.

                  One clarification: Seam doesn't support JSF 1.2 or Seam doesn't require JSF 1.2? 

                  To be honest, I don't know the significance of the difference between 1.1 and 1.2.  I'm guessing Seam will work either.  Correct?



                  Oops. Seam 2 requires JSF 1.2 and doesn't support JSF 1.1 was what I mean to say.