2 Replies Latest reply on Feb 28, 2012 5:23 AM by Lokesh Kumar Padhanvis

    HTTP Status 404 error at home.seam

    Khalid H Newbie

      Hi,


      I started an Seam project in Eclipse. In the begin is everything ok. I make some Beans and Entity's. My home.xhtml works fine when I type in the browser:


      http://localhost:8080/AjaxLab/home.seam


      But know I got this error:






      HTTP Status 404 - /AjaxLab/home.seam


      --------------------------------------------------------------------------------


      type Status report


      message /AjaxLab/home.seam


      description The requested resource (/AjaxLab/home.seam) is not available.



      --------------------------------------------------------------------------------


      JBossWeb/2.0.1.GA




      Does someone know how I can resolve this problem? I have build my project again, but I have the same error. First time its works ok. Later I get this error.

        • 1. Re: HTTP Status 404 error at home.seam
          Tomaz Cerar Master

          Hi,


          I had same problem, actually the problem is in bad error reporting in faclets that doesn't tell you what the real problem is.


          Somewhere in your templates where you probably use ui:include you try to include some file that doesn't exist. So when facelets try to include it they get 404 error, but instead that telling you that it could not include one fragment it reports 404 for whole page ie: home.seam.


          Just double check all your includes an make sure you don't have included something that doesn't exist.




          cheers,
          tomaz

          • 2. Re: HTTP Status 404 error at home.seam
            Lokesh Kumar Padhanvis Newbie

            Hi Tomaz

             

            Thanks for your suggestion!

            Recently I faced this issue, I have included a blank modal panel due to which i got the 404 for entire page.

            Your solution worked, again thanks a lot.