1 Reply Latest reply on Apr 6, 2008 7:24 PM by Pete Muir

    Deploying Seam in Jboss: which libs not to ship with?

    Gabriel Goïc Newbie

      Hello everyone,


      I'm currently trying to deploy a Seam 2.0.1-based webapp into Jboss AS 4.2.2, basically shipping all the jars in the Seam release.


      I'm running through several problems due to incompatible jars versions against those already provided by JBoss AS. I guess there is a list of jars one must not put in the WEB-INf/lib of a deployed app, like lo4j.jar or servlet-api.jar. Where can I find the complete list?
      I saw that the examples ship only a few libs with, but isn't it a risk to compile with up-to-date Seam jars and deploy into JBoss AS with its older jars for runtime? how to get my webapp to work with most of the Seam jars?


      Thanks for any help
      Gabriel