2 Replies Latest reply on May 1, 2008 4:27 PM by Jakub Hertyk

    How to disable seam filters

    Jakub Hertyk Newbie

      Hello,


      I see that by default Seam starts up any filters marked with the @Filter annotation in the core.  One of these filters is the org.jboss.seam.web.multipartFilter which is causing serious problems in the current application since there is a third party library handling the file upload.  I need to disable the multipartFilter so it doesn't wrap the HttpServletResponse in a MultipartResponse.  Any suggestions?




      Jakub

        • 1. Re: How to disable seam filters
          Clint Popetz Apprentice

          In components.xml, add:


               <web:multipart-filter disabled="true"/> 



          (and you can do that for any of the seam-installed filters.)


          • 2. Re: How to disable seam filters
            Jakub Hertyk Newbie

            Clint Popetz wrote on May 01, 2008 12:27 AM:


            In components.xml, add:

                 <web:multipart-filter disabled="true"/> 



            (and you can do that for any of the seam-installed filters.)




            Just as a follow up to the issue.  I tired the approach previously but it didn't work because forgot to include:



            xsi:schemaLocation="http://jboss.com/products/seam/web http://jboss.com/products/seam/web-2.0.xsd"
            



            along with:



            xmlns:web="http://jboss.com/products/seam/web"




            in the components.xml file.  Once I added the schema location, everything worked perfectly.


            Thanks,


            Jakub