1 Reply Latest reply on May 8, 2008 2:00 PM by Pete Muir

    AnnotationException when using certain annotations

    eric jung Newbie

      Hi,


      Using the 5 hibernate jars that come with Seam 2.0.1GA in the lib/ directory, my application gets this exception when I use certain annotations:


      org.hibernate.AnnotationException: java.lang.NoSuchMethodException: org.hibernate.validator.ClassValidator.apply(org.hibernate.mapping.PersistentClass)
              at org.hibernate.cfg.AnnotationConfiguration.secondPassCompile(AnnotationConfiguration.java:353)
              at org.hibernate.cfg.Configuration.buildMappings(Configuration.java:1115)


      It looks like hibernate-annotations.jar and/or hibernate-commons-annotations.jar isn't compatible with hibernate-validator.jar. I'm hesitant to upgrade these without upgrading hibernate.jar, which then requires me to upgrade lots and lots of other jars (e.g., antlr, javassist).


      Anyone know what to do?


      Thanks,
      Eric