6 Replies Latest reply on May 4, 2008 4:12 PM by Nobuyuki Inaba

    Hello world based on tutorial always gives PropertyNotFoundException

    Geoffrey De Smet Newbie

      Hi, I just started a simple hello world application, based on the tutorial in the manual, however I can't get rid of this error:


      javax.el.PropertyNotFoundException: /home.xhtml @22,75 action="#{employeeService.add}": Target Unreachable, identifier 'employeeService' resolved to null



      I have a employeeService:



      @Stateless
      @Name("employeeService")
      public class DefaultEmployeeService implements EmployeeService { ... }



      And the JBoss AS log clearly shows it's being deployed:



      7:32:16,781 INFO  [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=messor-ear.ear,jar=messor-ejb-0.1.0.jar,name=DefaultEmployeeService,service=EJB3 with dependencies:
      17:32:16,781 INFO  [JmxKernelAbstraction]      persistence.units:ear=messor-ear.ear,jar=messor-ejb-0.1.0.jar,unitName=messorPersistenceUnit
      17:32:16,781 INFO  [EJBContainer] STARTED EJB: be.messor.business.employee.DefaultEmployeeService ejbName: DefaultEmployeeService



      And my ejb-jar.xml contains:



          <interceptors>
              <interceptor>
                  <interceptor-class>org.jboss.seam.ejb.SeamInterceptor</interceptor-class>
              </interceptor>
          </interceptors>
      
          <assembly-descriptor>
              <interceptor-binding>
                  <ejb-name>*</ejb-name>
                  <interceptor-class>org.jboss.seam.ejb.SeamInterceptor</interceptor-class>
              </interceptor-binding>
          </assembly-descriptor>



      What am I missing?