0 Replies Latest reply on May 28, 2008 12:19 PM by Stephen Friedrich

    Better names for @Validator and @Converter

    Stephen Friedrich Novice

      Why the heck did someone came up with an annotation named Foo that can be applied to a class only if it implements another interface, also named Foo?!

      That leaves no choice, but to use an ugly, fully qualified name for one of it.

      A case in point is that the example in the seam reference will not compile (section 29.2. Annotations):

      public class ItemConverter implements Converter {

      How about deprecating those names and introducing something like @ConverterComponent