1 Reply Latest reply on Apr 15, 2009 2:40 PM by Adam Warski

    hibernate3-maven-plugin does not generate version tables

    Viktor Rees Newbie

      When using following maven plugin all 'normal' tables were generated normal. The problem is that for the versioned tables no ddl code is generated.

      When packaging the ear and deploy in JBoss all is fine. The versioned tables are generated well.

      <plugin>
       <groupId>org.codehaus.mojo</groupId>
       <artifactId>hibernate3-maven-plugin</artifactId>
       <version>2.2</version>
       <configuration>
       <components>
       <component>
       <name>hbm2ddl</name>
       <implementation>jpaconfiguration</implementation>
       </component>
       </components>
       <componentProperties>
       <export>no</export>
       <create>true</create>
       <drop>true</drop>
       <format>true</format>
       <jdk5>true</jdk5>
       <ejb3>true</ejb3>
       <haltonerror>true</haltonerror>
       <console>true</console>
       <outputfilename>schema.ddl</outputfilename>
       <persistenceunit>ImpactEntityManager</persistenceunit>
       <propertyfile>src/main/resources/hibernate.properties</propertyfile>
       </componentProperties>
       </configuration>
       <dependencies>
       <dependency>
       <groupId>com.oracle.jdbc</groupId>
       <artifactId>ojdbc6</artifactId>
       <version>11.1.0.6</version>
       </dependency>
       <dependency>
       <groupId>org.jboss.envers</groupId>
       <artifactId>jboss-envers</artifactId>
       <version>1.2.0.GA-hibernate-3.3</version>
       </dependency>
       </dependencies>
      </plugin>
      


      What could be the problem? Is there a debug feature to analyse the problem?