0 Replies Latest reply on Jun 14, 2008 1:02 AM by Carey Foushee

    Can't perform Ejb3 Lookup

    Carey Foushee Newbie

      I have successfully created an EJB3 Service using annotations, following the example from http://docs.jboss.org/ejb3/app-server/tutorial/service/service.html


      I have a ConnectionService that implements ConnectionServiceLocal,ConnectionServiceRemote, ConnectionServiceManagement and it gets created just fine and I can communicate with via JMX MBean View, and I can see its logging in the console window. 


      I used the Seam project wizard to create the Ear project I am using.  I am simply trying to do a look up on the Authenticator's authenticate() just to verify I can get a handle to it -- I won't really be using it there but I want to get this working before I move on.


      Here's the different things I've tried in the Authenticator class, but none have worked:


      1. @EJB ConnectionService con;

      2. @In  ConnectionService con;

      3. con = (ConnectionService)intialContext.lookup(name);
      Where name has been ConnectionService, ConnectionService/local, ConnectionService/remote , G7-core/ConnectionService

      I found documentation saying since my components.properties file contains

      jndiPattern=G7-ear/\#{ejbName}/local

      I should be able to just use the ConnectionService


      Both approach 1 & 2 give me NullPointerError, and approach 3 gives says:
      javax.naming.NameNotFoundException: ConnectionService not bound

      I also did try using the ConnectionServiceLocal in all 3 methods with exactly the same result.


      I can however use the JMX MBean Viewer to communicate with my EJB so I know its there.

      Here's the info from the JMX:

      MBean Name: Domain Name: jboss.j2ee

      service:  EJB3

      name:  ConnectionService

      ear:  G7-ear.ear

      jar:  G7-core.jar

      MBean Java Class: org.jboss.ejb3.ServiceDelegateWrapper