5 Replies Latest reply on Jun 17, 2008 4:45 PM by beyarecords

    Seam 2.0.3.CR1 build failure

    beyarecords Novice

      Hi,
      simply running ant cases a maven artifact missing error to be flagged on:



      1 required artifact is missing org.jboss.seam:jboss-seam:ejb:2.0.3.CR1




      I take it a generic seam.version property, 2.0.3.CR1, has been applied to the artifact ejb?


      Can you please fix this.


      My platform is:



      Win XP SP1
      JDK1.6.0_06



      Many thanks in advance.


      Andrew



        • 1. Re: Seam 2.0.3.CR1 build failure
          Jay Balunas Novice

          Could you take a look at your maven repository under org/jboss/seam/** and look there.  Do you see any 2.0.3.CR1 files or subdirectories?  Also could you post some more of the output?


          I am about to try this on my windows machine to see how it goes.


          Thanks,
          -Jay

          • 2. Re: Seam 2.0.3.CR1 build failure
            beyarecords Novice

            Hi Jay,
            there are currently 3 directories in the seam repository:


            1. embedded
            2. parent
            3. root


            I tried the build again this morning and the build was successful, although a warning was generated:


            Warning: skipping jar archive C:\jboss-seam-2.0.3\lib\interop\src\jboss--seam-jbas5-sources.jar because no files were included.



            As I wish to use Maven 2 to create, build and deploy any Seam projects, and being new to the world of Maven, could you please confirm which POM.xml I would need to use to create my initial Seam projects with, core.pom?


            Many thanks in advance.


            Andrew

            • 3. Re: Seam 2.0.3.CR1 build failure
              Jay Balunas Novice

              For your initial build issue - did that happen building the seam 2.0.3.CR1 distribution, or building your own project?


              I could not test on my Windows machine yesterday (long power outage from some thunderstorms), but I will double check this as soon as I can.  I wonder why the build is working now - if it did not before.  I will also look at the warning that you are seeing.  Looks like a spelling mistake jboss--seam-jbas5-sources.jar


              I will take a look at your other post regarding your pom.xml question.


              -Jay

              • 4. Re: Seam 2.0.3.CR1 build failure
                beyarecords Novice

                Jay Balunas wrote on Jun 17, 2008 15:25:


                For your initial build issue - did that happen building the seam 2.0.3.CR1 distribution, or building your own project?


                It happened when I was building the Seam 2.0.3.CR1 distribution. I simply cd'd into the distribution directory and ran 'ant' at the dos prompt.



                Jay Balunas wrote on Jun 17, 2008 15:25:

                I wonder why the build is working now - if it did not before.


                Yes, I thought this was a bit strange as well. The initail failed build built only 3 directories in org/jboss/seam, whilst the successful build has built 13.




                I will take a look at your other post regarding your pom.xml question.


                I have been looking at the following information:
                JBoss Seam project setup with Maven


                but I continue to get a 'badly formed maven project' error using Netbeans 6.1, in relation to the groupId, artifactId and version being uknown in the defined dependancies. Looking in org/jboss/seam/root/2.0.3-SNAPSHOT/ there are only a 1k resolver-status.properties and 1k root-2.0.3-SNAPSHOT.pom files. What is the issue here?


                My version:



                <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
                  <modelVersion>4.0.0</modelVersion>
                  <groupId>com.beyarecords.app</groupId>
                  <artifactId>beyarecords-seam-app</artifactId>
                  <packaging>pom</packaging>
                  <version>1.0-SNAPSHOT</version>
                  <name>beyarecords-seam-app</name>
                  <url>http://snapshots.jboss.org/maven2</url>
                  
                        <repositories>
                          <repository>
                            <id>jboss-snapshot</id>
                            <name>The JBoss Maven Repo</name>
                            <url>http://snapshots.jboss.org/maven2</url>
                          </repository>
                        </repositories>
                       
                        <parent>
                          <groupId>org.jboss.seam</groupId>
                          <artifactId>root</artifactId>
                          <version>2.0.3-SNAPSHOT</version>
                        </parent>
                
                        <!-- error being flagged with groupId, artifactId 
                             and version uknown in defined dependancies-->
                
                        <dependencies>
                          <dependency>
                            <groupId>log4j</groupId>
                            <artifactId>log4j</artifactId>
                            <scope>provided</scope>
                          </dependency>
                  
                          <dependency>
                            <groupId>junit</groupId>
                            <artifactId>junit</artifactId>
                            <scope>test</scope>
                          </dependency>
                        </dependencies>
                 
                        <modules>
                          <module>ejb</module>
                          <module>war</module>
                          <module>ear</module>
                        </modules>
                       
                        <build>
                          <plugins>
                            <plugin>
                              <groupId>org.apache.maven.plugins</groupId>
                              <artifactId>maven-compiler-plugin</artifactId>
                              <configuration>
                                <source>1.5</source>
                                <target>1.5</target>
                              </configuration>
                            </plugin>
                          </plugins>
                        </build>
                  
                </project>



                Many thanks in advance.


                Andrew

                • 5. Re: Seam 2.0.3.CR1 build failure
                  beyarecords Novice

                  Hi Jay,
                  in error I posted the last post here, instead of the 'missing dependencies' thread I started elsewhere. My appologies.


                  Andrew