4 Replies Latest reply on Jul 9, 2008 3:47 PM by Jay Balunas

    Weblogic 10 + Seam 2.0.2 GA + @Asynchronous

    Fábio Valente Newbie

      Hi,


      I'm working with Weblogic 10 with Seam 2.0.2 GA and I need to start a job after Seam startup. I used the annotation @Observer("org.jboss.seam.postInitialization") on a method that calls another method that has the annotation @Asynchronous. It works perfecty on JBoss 4.2.1 GA.


      I tried the three options that Seam has:



      • Not adding anything on components.xml

      • Adding <async:timer-service-dispatcher/> on components.xml

      • Adding <async:quartz-dispatcher/> on components.xml



      When I start Weblogic the method with the @Observer("org.jboss.seam.postInitialization") annotation is executed, but the one with @Asynchronous is never executed.


      I know that used to have a problem in using Weblogic with Seam due to varargs. And the problem was specifically involving asynchronous calls. I thought that it was solved on Seam 2.0.2 GA.


      Does any one have any idea how to solve this problem?


      Fábio.