3 Replies Latest reply on Sep 17, 2008 10:35 PM by judy guglielmin

    iText Example Does Not Work???

    Matt Galloway Newbie
      I've been struggling with iText PDF generation today so I thought I would take a step back.  I downloaded and installed that latest stable JBoss AS and Seam binaries and tried to run the iText demo. No matter whan link I click from the main page of the seam-itext application I get the message "The PDF you are trying to view is no longer available."

      Here's my environment:

      Mac OS X 10.5.4 (9E17) on Mac Pro (2 x 2.66Mhz Dual-Core Intel Xeon)

      java version "1.5.0_13"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05-237)
      Java HotSpot(TM) Client VM (build 1.5.0_13-119, mixed mode, sharing)

      jboss-4.2.3.GA
      jboss-seam-2.0.2.SP1

      I downloaded both zip files and unzipped them in a directory (~/java). 

      Configure the build.property file in the Seam main directory to point jboss_home to the JBoss directory.

      I then launched JBoss with run.sh

      I changed directory to examples/itext

      then "ant deploy"

      I pointed my browser at http://127.0.0.1:8080/seam-itext and got the main page correctly, but get the message I mentioned above no matter what link I clicked.

      I tried this after I failed earlier today to add PDF capabilities to a seam app I'm working on using a slightly older version of seam and Jboss.  The details of that error can be found here:

      http://seamframework.org/Community/NeedHelpWithITextPDF

      Any help appreciated.

      Thanks,

      Matt