12 Replies Latest reply on Nov 19, 2008 10:24 PM by Dmitry Shultz

    RichFaces problem with OS X

    David Salter Novice

      Hi,


      I'm using RichFaces with my Seam application and am doing the development on OS X.


      I'm finding that some of the RichFaces components cause Java on OS X to crash with a segmentation fault.


      Invalid memory access of location 2df4d000 eip=904716f9


      This happens with the simpleTogglePanel and the fileUpload component.


      Its not the browser that is crashing (Im aware of Safari issues with RichFaces), but Java hosting JBoss (4.2.2)


      Has anybody else seen this issue or know of a workaround?


      If I run my JBoss on Windows btw (JDK 6), I get no issues.


      Thanks,


      Dave.


        • 1. Re: RichFaces problem with OS X
          john hedden Newbie

          what version of RichFaces?  are you using FF?  I vaguely remember there being an issue with fileUpload in 3.2.0 and FF2 on mac.  try using RichFaces 3.2.1 and FF3.

          • 2. Re: RichFaces problem with OS X
            David Salter Novice

            I'm on RichFaces 3.2.0.


            I get the same problem with FF or Safari.  It seems to be the Java instance running JBoss that crashes and not the browser.


            I'll try 3.2.1 though and see if this is any different.

            • 3. Re: RichFaces problem with OS X
              David Salter Novice

              Thanks John,


              Upgrading to RichFaces 3.2.2 has fixed the issue.


              Looks like RichFaces 3.2.0 and OS X don't play happily together.

              • 4. Re: RichFaces problem with OS X
                Nazem Attar Newbie

                Hello,


                I'm running into the same problem, but with the new version of Richfaces. I had Richfaces 3.2.0 running smoothly under JBoss 4.2.2.GA on my Mac OS X (Tiger v. 10.4.11), and when I tried upgrading to RF 3.2.1 or 3.2.2 I got the same error Dave mentioned right after a browser calls my app's context (the app that runs Richfaces). The error I get is:


                Invalid memory access of location 43e83458 eip=904716f9

                bin/run.sh: line 246:  3201 Segmentation fault      "$JAVA" $JAVA_OPTS -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath "$JBOSS_CLASSPATH" org.jboss.Main "$@"


                and then the server halts. I tried this with IE6, IE7, FF3, Camino, and Safari 3, with the same results. The crash happens even though my app forwards to a login page that only has an <h:form> with username and password text fields, and a <h:commandButton> to execute the login action. I tried to run Richfaces 3.2.1 and 3.2.2 also under Tomcat 6 with JBoss embedded but it crashed as well (3.2.0 works fine).


                Any ideas or help is greatly appreciated. Thanks!


                --

                Nazem

                • 5. Re: RichFaces problem with OS X
                  Daniel Roth Apprentice

                  We had the same problems (and some other) with our Mac servers (tiger, leopard) to the extent that we've had to move most web apps to non mac servers (linux and recently windows). If that isn't an option for you, I suggest you send bug reports over and over again to Apple. I think the jvm on Apple is defect in some way.

                  • 6. Re: RichFaces problem with OS X
                    Nazem Attar Newbie

                    I actually have the same stack running on Leopard with no issues and a different app with a similar stack running on another computer with the same version of Tiger as I have. I should have also mentioned that I tried different versions of Seam (2.0.0.GA, 2.0.1.GA, 2.0.2.GA, and 2.1.0.BETA1) all with the same results.


                    Unfortunately, I have to use this Mac for development, and if I can't find the exact reason for what's happening, I might have to try to change the Java version on it, or upgrade to Leopard and see if that works. I will start sending out those crash reports to Apple though..


                    Thanks for your input, Daniel.

                    • 7. Re: RichFaces problem with OS X
                      Nazem Attar Newbie

                      Update: I found a post on the JBoss forums (http://jboss.com/index.html?module=bb&op=viewtopic&t=136650) that suggests the problem is Apple's quartz renderer, and a workaround for it is to run your server with the option "-Dapple.awt.graphics.UseQuartz=false" so if you're running JBoss AS it would be:


                      bin/run.sh -Dapple.awt.graphics.UseQuartz=false


                      I haven't tried this on Tomcat, but it worked for me on JBoss 4.2.2. Hope this helps.


                      --

                      Nazem

                      • 8. Re: RichFaces problem with OS X
                        John Pang Newbie

                        Hello,


                        I've just updated to seam 2.1.0.GA and deployed a very simple seam ap. As soon as I view a page the JVM crashes with the following error:


                        Invalid memory access of location 52b81000 eip=904706f9
                        ./run.sh: line 246:   262 Segmentation fault      "$JAVA" $JAVA_OPTS -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath "$JBOSS_CLASSPATH" org.jboss.Main "$@"


                        This happens consistently, every time I visit a page. If I revert back to seam 2.0.2.SP1 then it all works fine. What has changed between 2.1.0.GA and 2.0.2.SP1 that can cause this?


                        I'm running :


                        Mac Os X 10.4.11.


                        Java 1.5.0_16-b06-275.


                        JBoss-4.2.3.GA.


                        I've tried using the -Dapple.awt.graphics.UseQuartz=false system property suggested in the previous post but that doesn't help. :(


                        Anybody shed any light on this? I really don't want to have to abandon Mac Os X...


                        Cheers,


                        John

                        • 9. Re: RichFaces problem with OS X
                          John Pang Newbie

                          I'm really stuck on this one...


                          Could it be anything to do with this?
                          http://raymesk.blogspot.com/2008/09/java-6-on-mac-os-x-with-sunspots.html


                          It's suggesting some stuff compiled using java 6 might not like being run on Mac Os X? :(

                          • 10. Re: RichFaces problem with OS X
                            Stefan Kohler Newbie

                            Any updates on the topic yet? I'm having the same problems on Mac OS X 10.4.11, JBoss AS 4.2.3 and Seam 2.1.0 SP1.


                            Thanks.

                            • 11. Re: RichFaces problem with OS X
                              Stefan Kohler Newbie

                              So I downgraded to Seam 2.0.2.SP1 (still use JBoss AS 4.2.3.GA) and the simple CRUD app works now. I have no glue why? Any ideas?

                              • 12. Re: RichFaces problem with OS X
                                Dmitry Shultz Newbie

                                The first thing I'm doing after Glassfish installation on my OS X Server is configuring the

                                -Djava.awt.headless=true

                                jvm option for glassfish.


                                Not sure if it will helps, but it was not mentioned here so far.