1 Reply Latest reply on Oct 15, 2008 1:05 AM by Carlos Diógenes

    help: seam generate don't find javac

    Carlos Diógenes Newbie

      Hi,


      I'm using Ubuntu 8.04 and have sun-java-jdk installed.


      I downloaded jboss-seam-2.0.2.GA and went into the cycle to create a new project.


      When I run the command: ./seam generate


      I get the following errors:



      BUILD FAILED
      /home/cerodrigues/Downloads/Java/jboss-seam-2.0.2.SP1/seam-gen/build.xml:1125: The following error occurred while executing this line:
      /home/cerodrigues/workspace/teste/build.xml:60: Unable to find a javac compiler;
      com.sun.tools.javac.Main is not on the classpath.
      Perhaps JAVA_HOME does not point to the JDK.
      It is currently set to "/usr/lib/jvm/java-6-sun-1.6.0.07/jre"
      
      Total time: 6 seconds
      



      I don't know from where this JAVA_HOME is being setted by seam, but I tried to change it in all always that I can think, but I also get this same message saying that it's currently setted to something totally diferente from what I setted.


      Any hint,


      Thanks,
      Carlos.