1 Reply Latest reply on Oct 28, 2008 11:47 AM by shawn young

    Page Action Lost in concurrent Test

    shawn young Newbie

      Page Action Lost in concurrent Test.


      Seam2.0.0.GA JBoss4.2.


      It seems seam will lost action in concurrent access.


      1. i have a page using get method to init


      <page view-id="/resource/metadata/subjectDataList.xhtml" action="#{subjectDataList.init}">
                <param name="subjectId" value="#{subjectDataList.dataSubjectId}" />     
      </page>
      



      2. and my action bean like


      @Scope(PAGE)
      @Name("subjectDataList")
      public class SubjectDataList implements ISubjectDataList, Serializable
      {
       ...
         @Logger
         private Log log;
      
         public void init()
         {     
             log.debug("querySubjectData call.");
             ...
         }
       ...
      }
      



      3. my test page: test.html


      <table>          
           <tr>
                <td>
                <iframe     src="http://172.16.8.169:8080/subjectDataList.seam"></iframe>
                </td>
                <td>
                <iframe     src="http://172.16.8.169:8080/subjectDataList.seam"></iframe></td>
           </tr>
           <tr>
                <td>
                <iframe     src="http://172.16.8.169:8080/subjectDataList.seam"></iframe>
                </td>
                <td>
                <iframe     src="http://172.16.8.169:8080/subjectDataList.seam"></iframe></td>
           </tr>
      </table>
      







      Access the test page, the console output should that it always lost the action init.
      Sometime all four debug show out, but something lost one or two or three.


      why? is it seam' buy, or am i make a mistake?