3 Replies Latest reply on Feb 28, 2008 2:55 PM by Jason S. Vorpahl

    Use With JRE 1.4.2

    Jason S. Vorpahl Newbie

      I am getting started w/JSFUnit and ran into a problem.

      I downloaded the most recent jar (jboss-jsfunit-core-1.0-beta-1.jar) from the download site and added it along w/the other required libraries to my JSF web project and configured the web.xml file. When starting up the application, I am gettnig a bad major version when loading the JSFUnit.

      My questions are as follows:

      1.) Is JSFUnit not compatible with Java 1.4.2?
      2.) Can I correct this problem by downloading the source from SVN and building it using 1.4.2?

      Here is my enviroment information:

      - Server: Websphere Application Server v6.0
      - java version "1.4.2" ; Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2) ; Classic VM (build 1.4.2, J2RE 1.4.2 IBM Windows 32 build cn142sr1w-20041028 (JIT enabled: jitc))
      - IBM JSF 1.0

      Here is a summary of the error:

      [2/27/08 9:09:04:275 CST] 00000042 SystemErr R java.lang.LinkageError: LinkageError while defining class: org.jboss.jsfunit.context.JSFUnitFacesContextFactory
      Could not be defined due to: (org/jboss/jsfunit/context/JSFUnitFacesContextFactory) bad major version at offset=6
      This is often caused by having a class defined at multiple
      locations within the classloader hierarchy. Other potential causes
      include compiling against an older or newer version of the class
      that has an incompatible method signature.
      Dumping the current context classloader hierarchy:
       ==> indicates defining classloader