1 Reply Latest reply on Nov 6, 2008 11:25 PM by Dean Hiller

    Apply Request Values fails but no validator.failed

    Dean Hiller Expert

      Well, I finally figured out why my method is not being called and am wondering if this is a seam issue......


           public void invalid() {
                facesMessages.add("Errors below in form.  Please correct and resubmit");
           }



      then in pages.xml, I have the typical action...



          <page view-id="/secure/admin/script/*" conversation-required="true">
              <action if="#{validation.failed}" execute="#{globalMethods.invalid()}"/>
      



      Now, it turns out, this method works GREAT if and only if the JSF lifecylce gets to the validation phase.  For some odd reason, in one scenario in my web application, it is going from apply request values phase straight to render response phase.  I have two questions...



      1. shouldn't this action be called just like validation failure?
      2. How do I even determine why it is not going to the validation
       phase?  Is there any debug logs I can turn on? I tried turning 
      seam up to fine(big mistake) and JSF to fine, but nothing worked.
      



      ie. how do I debug this problem further myself?
      thanks,
      Dean