4 Replies Latest reply on Aug 8, 2008 3:26 AM by Peter Treitler

    Problems when trying to run JSFUnit tests in browser

    Peter Treitler Newbie

      Hello,

      I have written some JSFUnit tests according to the getting started guide. Now when i try to run them in the browser i get the following:

      HTTP Status 500 -
      
      type Exception report
      
      message
      
      description The server encountered an internal error () that prevented it from fulfilling this request.
      
      exception
      
      javax.servlet.ServletException: Servlet execution threw an exception
       org.jboss.jsfunit.framework.JSFUnitFilter.doFilter(JSFUnitFilter.java:122)
      
      root cause
      
      java.lang.NoClassDefFoundError: junit/runner/TestSuiteLoader
       org.apache.cactus.server.runner.ServletTestRunner.run(ServletTestRunner.java:297)
       org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody0(ServletTestRunner.java:187)
       org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody1$advice(ServletTestRunner.java:225)
       org.apache.cactus.server.runner.ServletTestRunner.doGet(ServletTestRunner.java:1)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
       org.jboss.jsfunit.framework.JSFUnitFilter.doFilter(JSFUnitFilter.java:122)
      
      root cause
      
      java.lang.ClassNotFoundException: junit.runner.TestSuiteLoader
       org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
       org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
       java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
       org.apache.cactus.server.runner.ServletTestRunner.run(ServletTestRunner.java:297)
       org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody0(ServletTestRunner.java:187)
       org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody1$advice(ServletTestRunner.java:225)
       org.apache.cactus.server.runner.ServletTestRunner.doGet(ServletTestRunner.java:1)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
       org.jboss.jsfunit.framework.JSFUnitFilter.doFilter(JSFUnitFilter.java:122)
      
      note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.
      Apache Tomcat/6.0.18


      I do have all the .jars mentioned in the guide in my WEB-INF/lib.

      Can anybody help me with this problem?

      Thanks.