3 Replies Latest reply on Aug 1, 2011 12:41 PM by Phil Haigh

    Strange seam mail attachment issue

    Travis De Silva Newbie

      I am having a very strange seam mail attachment issue.


      When I run my app in my Ubuntu 8.04 development platform via the Postfix SMTP service and Dovecot pop3 server, the seam email attachment works fine.


      But when I move the app to production servers that use Red Hat Enterprise Linux ES release 4 (Nahant Update 6) and Microsoft exchange, the attachments are not received. (but the email itself is received)


      When I enable debugging to true in the mail-service.xml in JBoss, it shows the attachment file text on the console which indicates that seam has processed the mail attachment properly.


      To narrow down the issue, I ran a direct Java mail class (by passing seam mail but activated from a seam component) that sends an attachment off the RedHat server and it worked fine. So there is no size or any other limit issue set in Microsoft exchange or any issue with JBoss or Java.


      I use the same Jboss version on both servers but on Ubantu I use Java 1.6.007 and on RedHat I use 1.6.011. (but the default Java 1.4 is also present on the server but is not used for JBoss App server)


      Any ideas what could be causing this issue.