4 Replies Latest reply on Mar 5, 2009 7:47 PM by Francisco Jose Peredo Noguez

    ManagedEntityInterceptor

    marx3 Apprentice

      As I see ManagedEntityIndentityInterceptor is renamed to ManagedEntityInterceptor. I've read it causes performance problem and can be switched off when clustering isn't used.
      There is Jira issue saying that possibility to switch it off is done. But there is no such option in <core:init> in components.xml. There are no examples how to do that. I've read somewhere that now it's switched off by default, is it true? How to check it?

        • 1. Re: ManagedEntityInterceptor
          marx3 Apprentice

          Is it proper way to do that?



          <core:init debug="true" jndi-pattern="@jndiPattern@" >
                    <core:interceptors>
                     <value>org.jboss.seam.core.SynchronizationInterceptor</value>
                     <value>org.jboss.seam.async.AsynchronousInterceptor</value>
                     <value>org.jboss.seam.ejb.RemoveInterceptor</value>
                     <value>org.jboss.seam.persistence.HibernateSessionProxyInterceptor</value>
                     <value>org.jboss.seam.persistence.EntityManagerProxyInterceptor</value>
                     <value>org.jboss.seam.core.MethodContextInterceptor</value>
                     <value>org.jboss.seam.core.EventInterceptor</value>
                     <value>org.jboss.seam.core.ConversationalInterceptor</value>
                     <value>org.jboss.seam.bpm.BusinessProcessInterceptor</value>
                     <value>org.jboss.seam.core.ConversationInterceptor</value>
                     <value>org.jboss.seam.core.BijectionInterceptor</value>
                     <value>org.jboss.seam.transaction.RollbackInterceptor</value>
                     <value>org.jboss.seam.transaction.TransactionInterceptor</value>
                     <value>org.jboss.seam.webservice.WSSecurityInterceptor</value>
                     <value>org.jboss.seam.security.SecurityInterceptor</value>
                     <!-- Disable ManagedEntityInterceptor
                          <value>org.jboss.seam.persistence.ManagedEntityInterceptor</value>-->
                       </core:interceptors>
               </core:init>


          • 3. Re: ManagedEntityInterceptor
            Marius Oancea Novice
            Simpler is to say:
            <core:init debug="true" jndi-pattern="@jndiPattern@" distributable="false">


            • 4. Re: ManagedEntityInterceptor
              Francisco Jose Peredo Noguez Master

              And AFAIK is now disabled by default (so you do not need to worry about it unless you want to enable it)