3 Replies Latest reply on Feb 26, 2009 11:06 PM by Max Tomlinson

    GWT + Seam remoting problems

    Rutton R Newbie

             Hi,


      I am using seam and gwt and have difficulties getting a homegrown variant of the examplecode (from here: http://docs.jboss.org/seam/2.1.0.A1/reference/en/html/gwt.html ) to run succesfully.
      The gwt Button works fine, but after a press on the button of the example, there should a remoting happen, but the only thing I get is a 404 The requested resource (/SEAMTest/com.gwtjboss.GwtJbossTry/seam/resource/gwt) is not available
      The described missing of the gwt-servlet.jar, described here: http://www.seamframework.org/Community/GWTAndSeamRemotingProblems, can't be the problem as I already had added this to the lib of the ear.


      What I would know is, what options do I have to find the mistake? Is there a way to find out what seam resources my ear-file is installing and where they are located?


      Regards,
      Rut.

        • 1. Re: GWT + Seam remoting problems
          Rutton R Newbie

          To add:
          I believe to have everything cross-checked with the original example, like deployment descriptors, service implementations and such. But still no success. Atm. I digging around in the jboss administration console, but still no clue where the problem is or how I can find why it is not working.

          • 2. Re: GWT + Seam remoting problems
            Rutton R Newbie

            Allright. The problem turned out as a failure in the deployment. The gwt compiler creates a tree (which results in the specific url /SEAMTest/com.gwtjboss.GwtJbossTry/... for all gwt stuff) and seam wants a flat url /SEAMTest/seam/resource/gwt). Both don't fit together.
            Now I have a different error ;-( but I will figure that out as well.

            • 3. Re: GWT + Seam remoting problems
              Max Tomlinson Newbie

              I am having a problem with the example code as well although I am not compiling with GWT at this point; rather I am adding the generated GWT files fromt he example to my view directory and compiling the java code. I've changed the HelloWorld.html to HelloWorld.xhtml (Can I do this? I don't believe earlier versions of GWT worked with xhtml).
              Anyway, after I press the 'ask' key I get a 404 and 'the requested resource() is not available' - I've checked all the deployment directories on my jboss server and everything looks like it's there.
              many thanks
              Max