5 Replies Latest reply on Jun 15, 2009 4:29 PM by Julien Kronegg

    Setting debug="false" in components.xml prevents initialization of @Startup bean during server startup

    Sheldon S Newbie
      I am using SEAM 2.1.1GA + JBoss 4.2.2. When I change <core:init debug="true"../> to <core:init debug="false" .../>, beans annotated with

      @Startup
      @Scope(ScopeType.APPLICATION)

      no longer have their @Create method executed.

      The reason for this change is that the pages render too slowly under Seam 2.1.1GA. There were suggestions that changing debug setting will make rendering faster.

      Any solutions? Thanks.

      Sheldon