1 Reply Latest reply on Apr 9, 2009 2:46 PM by Gregory Nikle

    Users are very often logged out withour reason. ;(

    Gregory Nikle Apprentice

      Hi,
      Users report me that they are very often logged out.
      I don't know how to resolve that.


      My page is created in Seam 2.0.1GA, Facelets,richfaces, Jboss 4.2.1
      In previous 1.2.1GA version everythink was fine.


      Sesion in web.xml is set to 20minutes. but users reports they are logged out after less than minute, and this happen very randomly.


      there is no errors in console without FacesMessages message like Please login first.


      Can anybody help tell me can be wrong?


      I don't use Drools in my security, just siply rules user/admin and logged in.


      My rules file


      package SGUniPermissions;
      
      import java.security.Principal;
      
      import org.jboss.seam.security.PermissionCheck;
      import org.jboss.seam.security.Role;
      
      rule AdminIsAUser
        salience 10
        no-loop
      when
        Role(name == "admin")
        not Role(name == "user")
      then
        insert(new Role("user"));
      end
      
      



      components.xml


      <?xml version="1.0" encoding="UTF-8"?>
      <components xmlns="http://jboss.com/products/seam/components"
                  xmlns:core="http://jboss.com/products/seam/core"
                  xmlns:async="http://jboss.com/products/seam/async"
                  xmlns:persistence="http://jboss.com/products/seam/persistence"
                  xmlns:security="http://jboss.com/products/seam/security"
                  xmlns:transaction="http://jboss.com/products/seam/transaction"
                  xmlns:drools="http://jboss.com/products/seam/drools"
                  xmlns:theme="http://jboss.com/products/seam/theme"
                  xmlns:web="http://jboss.com/products/seam/web"
                  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                  xsi:schemaLocation=
                      "http://jboss.com/products/seam/core http://jboss.com/products/seam/core-2.0.xsd
                       http://jboss.com/products/seam/async http://jboss.com/products/seam/async-2.0.xsd
                       http://jboss.com/products/seam/persistence http://jboss.com/products/seam/persistence-2.0.xsd
                       http://jboss.com/products/seam/transaction http://jboss.com/products/seam/transaction-2.0.xsd
                       http://jboss.com/products/seam/security http://jboss.com/products/seam/security-2.0.xsd
                       http://jboss.com/products/seam/theme http://jboss.com/products/seam/theme-2.0.xsd
                       http://jboss.com/products/seam/web http://jboss.com/products/seam/web-2.0.xsd
                       http://jboss.com/products/seam/components http://jboss.com/products/seam/components-2.0.xsd
                       http://jboss.com/products/seam/drools http://jboss.com/products/seam/drools-2.0.xsd">                 
      
          <!-- <core:init jndi-pattern="@jndiPattern@" debug="false"/>-->
          <core:init jndi-pattern="sguni/#{ejbName}/local" debug="false"/>
       
          <core:manager conversation-timeout="60000"
                        concurrent-request-timeout="500"
                        conversation-id-parameter="cid"/>          
          
          <security:identity authenticate-method="#{authenticator.authenticate}" remember-me="true" />
          
          <web:multipart-filter create-temp-files="true" 
                                max-request-size="1000000" 
                                url-pattern="*.seam"/>
                                      
          <drools:rule-base name="securityRules">
              <drools:rule-files><value>/META-INF/security-rules.drl</value></drools:rule-files>
          </drools:rule-base>                                
                                
          <persistence:managed-persistence-context name="sguniAdm"
                                            auto-create="true"
                                            persistence-unit-jndi-name="java:/SGUniAdmEntityManagerFactory" />
                                            
          <persistence:managed-persistence-context name="sguniOneEM"
                                            auto-create="true"
                                            persistence-unit-jndi-name="java:/SGUniOneEntityManagerFactory" />
                                            
          <persistence:managed-persistence-context name="sguniTwoEM"
                                            auto-create="true"
                                            persistence-unit-jndi-name="java:/SGUniTwoEntityManagerFactory" />
          
          <component name="org.jboss.seam.remoting.remoting">
            <property name="debug">false</property>
          </component>    
              
          <factory name="remoteAddr" value="#{facesContext.externalContext.request.remoteAddr}"/>   
           <theme:theme-selector cookie-enabled="true" />          
              <async:quartz-dispatcher/>    
      </components>