3 Replies Latest reply on Apr 28, 2009 5:50 PM by aozoren

    jboss tools issue

    aozoren Newbie

      Following combination does not copy jboss-seam.jar to deploy directory and deployment fails..


      eclipse-jee-europa-winter


      JBossTools-2.1.2.GA


      manually copying said file inside ear file in deploy directory, jboss  redeploys, and it works..


      are those plugins tested before posted on the web since ganymede/tools3 combination does not work at all and i had to revert back to europa/tools2..

        • 1. Re: jboss tools issue
          aozoren Newbie

          what is causing the problem is the following declaration in the application.xml.. it should not be there in the first place and removing it solves the problem and it seems like a bug..




                  <module>
                          <ejb>jboss-seam.jar</ejb>
                  </module>
          
          


          • 2. Re: jboss tools issue
            Max Andersen Newbie

            ali ozoren wrote on Apr 25, 2009 13:39:


            Following combination does not copy jboss-seam.jar to deploy directory and deployment fails..

            eclipse-jee-europa-winter

            JBossTools-2.1.2.GA

            manually copying said file inside ear file in deploy directory, jboss  redeploys, and it works..

            are those plugins tested before posted on the web since ganymede/tools3 combination does not work at all and i had to revert back to europa/tools2..


            Yes, they are tested and any issues like this one is documented in the release blogs-notes. Here the missing copying is caused by a bug in Eclipse WTP 2.x which means you either need to use a patch (provided in the release blog) or remove the module entry in application.xml which though disables the ejb3 tx integration.


            About Ganymede-Tools 3 then what do you mean by not working at all ? It works fine for a lot of users so would be great to hear what you are having specific problems with ?

            • 3. Re: jboss tools issue
              aozoren Newbie

              Max - The crash problem, which turns out to be a real problem for other mac users as well, has been resolved today on http://seamframework.org/Community/JbossOrSeamCrashOnOsX thread.. As for the WTP 2.x, I think whatever patch was necessary should have been included in the latest release on their web site because it ruins the 'out-of-box' experience. Once you download the latest and greatest, you expect it to work out of the box. Thanks for the comment.