2 Replies Latest reply on Jul 7, 2009 2:32 AM by Muhammed Patel

    Spring and Envers

    Muhammed Patel Newbie

      Hi there,
      Please forgive me if this post has existed before but i have been trauing the net for the past week trying to find an answer. :)

      I am using spring 2.5.6 , hibernate 3.3 and have been trying to integrate Hibernate Enver 1.2.0 into my app.

      It seems that i get the tables to be created and the application starts up fine but when i make an update , create or delete my table is not populated with any data .

      My application-context.xml is as follows.

      <?xml version="1.0" encoding="UTF-8"?>
      <beans xmlns="http://www.springframework.org/schema/beans" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">
      <!-- START - IFA DATASOURCE AND SESSION FACTORY-->
      <!-- Below are connection values to the database. These values are used in the hibernate.properties file and are populated at runtime-->
      <bean id="ifaDataSource" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">

      net.sourceforge.jtds.jdbc.Driver


      jdbc:jtds:sqlserver://localhost:1433/ifa;prepareSQL=0;SendStringParametersAsUnicode=False;


      ifa


      ifa


      2


      5


      2







      WEB-INF/hibernate/hibernate-ifa.cfg.xml


      org.hibernate.cfg.AnnotationConfiguration



      org.hibernate.dialect.SQLServerDialect
      true
      true
      <!-- update -->
      true

















































      <!-- END - IFA DATASOURCE AND SESSION FACTORY-->




      Also i have added the @Audited annotation to my bean.

      Any help would be much appreciated as i cannot find any resources for this problem.

      Many Thanks,
      Muhammed Patel