5 Replies Latest reply on Dec 9, 2009 3:25 PM by Marcel Kolsteren

    Seam & SAML 2.0 with JBoss Identity

    Jack C Newbie

      I am trying to integrate Seam with JBoss Identity to provide a Service Provider side SAML 2.0 implementation.

      Our environment is JBoss 4.2.2 / Seam 2.1.1.GA. I was reading the articles on JBoss wiki

      1) http://www.jboss.org/community/wiki/seamintegrationwithjbossidentity
      2)http://www.jboss.org/community/wiki/JBossSeamsupportforWebBrowserSSOProfile

      All of them seem to indicate that JBoss 5.x is required for JBoss Identity to work. Is that true or can it work on JBoss 4.2.2 also?

      That aside, I wanted to get the examples working on the env as prescribed and I downloaded JBoss 5.1 and JBoss Identity 1.0.0. Beta3 and tried to get the examples mentioned in the article no 2 to work. I got past the road block as mentioned in this article
      http://www.jboss.org/index.html?module=bb&op=viewtopic&t=163342

      But I am getting the following error.
      java.lang.ClassNotFoundException: org.jboss.identity.federation.bindings.tomcat.KeyStoreKeyManager

      and sure enough none of the three jar files that are part of the JBoss Identity distro contains this class. Is this class obsolete now? Please let me know if there is a workaround for this issue.

      Thanks in advance