3 Replies Latest reply on Jul 2, 2009 9:58 PM by Christian Bauer

    Connection refused: connect... What ???

    Rodrigo Moraes de Oliveira Newbie

      My project is showing this error....


      org.netbeans.api.debugger.jpda.DebuggerStartException: Connection refused: connect
              at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.waitRunning(JPDADebuggerImpl.java:425)
              at org.netbeans.api.debugger.jpda.JPDADebugger.attach(JPDADebugger.java:263)
              at org.netbeans.modules.debugger.jpda.ant.JPDAConnect$1.run(JPDAConnect.java:212)
              at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:577)
              at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1030)
      Caused by: java.net.ConnectException: Connection refused: connect
              at java.net.PlainSocketImpl.socketConnect(Native Method)
              at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
              at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
              at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
              at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
              at java.net.Socket.connect(Socket.java:519)
              at com.sun.tools.jdi.SocketTransportService.attach(SocketTransportService.java:204)
              at com.sun.tools.jdi.GenericAttachingConnector.attach(GenericAttachingConnector.java:98)
              at com.sun.tools.jdi.SocketAttachingConnector.attach(SocketAttachingConnector.java:72)
              at org.netbeans.api.debugger.jpda.AttachingDICookie.getVirtualMachine(AttachingDICookie.java:220)
              at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:187)
              at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
              at org.netbeans.modules.debugger.jpda.actions.StartActionProvider$1.run(StartActionProvider.java:163)
      



      persistence-prod.xml:


      <?xml version="1.0" encoding="UTF-8"?>
      <!-- Persistence deployment descriptor for prod profile -->
      <persistence version="1.0" xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd">
        <persistence-unit name="cvhnet">
          <no-jta-data-source>cvhnetDatasource</no-jta-data-source>
          <!-- The <jar-file> element is necessary if you put the persistence.xml in the WAR and the classes in the JAR -->
          <!--
            <jar-file>../../vehicles.jar</jar-file>
            -->
          <provider>org.hibernate.ejb.HibernatePersistence</provider>
          <properties>
            <property name="hibernate.dialect" value="org.hibernate.dialect.OracleDialect"/>
            <property name="hibernate.jdbc.batch_size" value="20"/>
            <property name="hibernate.default_schema" value="CVHNET"/>
            <property name="jboss.entity.manager.factory.jndi.name" value="java:/cvhnetEntityManagerFactory"/>
            <property name="hibernate.connection.username" value="cvhnet"/>
            <property name="hibernate.connection.driver_class" value="oracle.jdbc.driver.OracleDriver"/>
            <property name="hibernate.connection.password" value="CVHNET"/>
            <property name="hibernate.connection.url" value="jdbc:oracle:oci8:@172.27.17.20:1521:XE"/>
          </properties>
        </persistence-unit>
      </persistence>