1 Reply Latest reply on Jul 6, 2009 10:26 PM by David Cooper

    Upgrade to seam 2.1.2 and Jboss 5.0

    David Cooper Newbie

      I just upgraded from Jboss 4.x to JBoss 5.0 with seam 23.1.2 and my converters broke.  I was injecting the entity manager thusly:



      @In EntityManager entityManager;



      Upgrading to JBoss 5.0 with seam 2.1.2 and I had to add @BypassInterceptors to all my converters and my entityManager is null. 


      I can't user @PersistenceContext because my converters are simple java objects.  How do I get an entityManager in my converters now?  Do I have to make them all Stateless SessionBeans?