1 Reply Latest reply on Jan 6, 2011 5:05 PM by Ben Groeneveld

    Web Services issue

    Monkey Den Master

      Seam 2.1.1
      JBossWS 3.0.1


      I have the following 2 files, making up my Seam web service.  The EJB itself seems to deploy fine but the endpoint isn't registered.  All the WS seems to be in place, so I wonder if it's something to do with Seam.  I do have the standard-jaxws-endpoint-config.xml file in the EJB META-INF directory.


      When I check http://localhost:8080/jbossws/services I can see others, but not this one.  Thanks


      @WebService
      @SOAPBinding(style = Style.RPC) // more on this later
      public interface TimeServer {
          String getTimeAsString();
          long getTimeAsElapsed();
      }
      



      @WebService(endpointInterface="com.symcare.intouch.services.TimeServer")
      @Remote(TimeServer.class)
      @Stateless
      @Name("timeServer")
      public class TimeServerImpl implements TimeServer {
          @WebMethod
          public String getTimeAsString() {
              Date time = new Date();
              System.out.println("TimeAsString: " + time.toString());
              return time.toString();
          }
          @WebMethod
          public long getTimeAsElapsed() {
              Date time = new Date();
              System.out.println("TimeAsElapsed: " + time.toString());
              return time.getTime();
          }
      }
      

        • 1. Re: Web Services issue
          Ben Groeneveld Newbie

          We cannot get this to work either with standard-jaxws-endpoint-config.xml.  Only if we modify the web.xml and add the web services as servlets does it work.  Then they show up in /jbossws/services.  We are wondering of this is because we are deploying a war and not an ear - we've seen some related posts seeing no luck with the endpoint config in wars.