Since PagingManager is now doing a bit more than just Paging (blockings, dropping and paging), I thought about renaming:
PagingManager to MemoryManager
PagingStore to AddressMemoryManager
The stuff that is on MemoryManager now could be moved to the new MemoryManager.
This would be a simple renaming, I don't think it would cause any issues.
I would do this after I closed my current tasks of course. Any objections?
Add a JIRA for 2.1 if you like