3 Replies Latest reply on Jan 12, 2010 7:37 AM by bsgcic

    2.1.2.GA -> 2.2.0.GA - BPM process parse warning. Code equivalent.

    bsgcic Newbie

      The following warning arises in 2.2.0.GA but not 2.1.2.GA.

      (Only differences in 2.1.2.GA, version is pageflow-2.1.xsd and http://jboss.com/products/seam/bpm-2.1.xsd):


      08:56:40,609 WARN  [JpdlXmlReader] process parse warning: line 17: schema_reference.4: Failed to read schema document 'http://jboss.com/products/seam/pageflow-2.2.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.


      quotepageflow.jpdl.xml:


      <pageflow-definition 
      xmlns="http://jboss.com/products/seam/pageflow" 
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
      xsi:schemaLocation="
       http://jboss.com/products/seam/pageflow 
       http://jboss.com/products/seam/pageflow-2.2.xsd" 
       name="quote">
      
      <start-page name="startQuote" view-id="/quote.xhtml">
       <redirect/>
      </start-page>
           
      </pageflow-definition>
      



      components.xml


      xmlns:bpm="http://jboss.com/products/seam/bpm"
      
      And inside xsi:schemaLocation is the following:
      http://jboss.com/products/seam/bpm
      http://jboss.com/products/seam/bpm-2.2.xsd
      
      <bpm:jbpm>
       <bpm:pageflow-definitions>
        <value>quotepageflow.jpdl.xml</value>
       </bpm:pageflow-definitions>
      </bpm:jbpm>
      
      



      Anyone else encountering this warning when moving to 2.2.0.GA?

      Ideas?