1 Reply Latest reply on Jan 26, 2010 2:54 AM by Nikolay Elenkov

    Is this possible two seam version crash tomcat?

    Gregory Nikle Apprentice

      Hi,
      I've got 3 web applications on tomcat 6 nad java 1.5.22.
      Two of applications works on new Seam 2.2.0 GA, third works on Seam 2.0.1GA.


      Each application have jars in own WEB-INF/lib directory.
      Previously I had 2 servers with same configuration, but the Seam 2.0.2 apps worked on different tomcat and third worked on other tomcat.
      Now they work on same tomcat server and here I got problem. Tomcat works for a day, half day, two days. Maximum 3 days and after that it gets down with error message.




      #
      # An unexpected error has been detected by HotSpot Virtual Machine:
      #
      #  SIGSEGV (0xb) at pc=0xb7962d4f, pid=3307, tid=1355598736
      #
      # Java VM: Java HotSpot(TM) Server VM (1.5.0_22-b03 mixed mode)
      # Problematic frame:
      # V  [libjvm.so+0x402d4f]
      #
      # An error report file with more information is saved as hs_err_pid3307.log
      #
      # If you would like to submit a bug report, please visit:
      #   http://java.sun.com/webapps/bugreport/crash.jsp
      #



      I checked memory in the log file and it looks fine. Take a look at the log



      #
      # An unexpected error has been detected by HotSpot Virtual Machine:
      #
      #  SIGSEGV (0xb) at pc=0xb7962d4f, pid=3307, tid=1355598736
      #
      # Java VM: Java HotSpot(TM) Server VM (1.5.0_22-b03 mixed mode)
      # Problematic frame:
      # V  [libjvm.so+0x402d4f]
      #
      
      ---------------  T H R E A D  ---------------
      
      Current thread (0x096d1948):  VMThread [id=3312]
      
      siginfo:si_signo=11, si_errno=0, si_code=1, si_addr=0x40000000
      
      Registers:
      EAX=0x40000001, EBX=0xb7b29bd0, ECX=0x000045d7, EDX=0x40000000
      ESP=0x50ccba3c, EBP=0x50ccba48, ESI=0xb7b1ab58, EDI=0xb7b1ab50
      EIP=0xb7962d4f, CR2=0x40000000, EFLAGS=0x00010207
      
      Top of Stack: (sp=0x50ccba3c)
      0x50ccba3c:   b7b29bd0 09659d28 09614ad0 50ccbb18
      0x50ccba4c:   b777611f b7b29bd0 50ccbac0 50ccbab8
      0x50ccba5c:   b7a02ae6 09659d28 09614ad0 50ccba80
      0x50ccba6c:   50ccba90 30074788 09614ad0 50ccbad0
      0x50ccba7c:   00000000 09659d28 09659f10 9555aa00
      0x50ccba8c:   b7a02ada 00000000 00000001 00000001
      0x50ccba9c:   00000000 00000000 00000000 b7a029cb
      0x50ccbaac:   00000000 09659c88 09603880 50ccbb08 
      
      Instructions: (pc=0xb7962d4f)
      0xb7962d3f:   b3 1c 0d 00 00 8b 06 8d 04 c8 41 8b 10 8b 40 04
      0xb7962d4f:   89 02 3b 0f 72 ef 8b bb e4 2d 00 00 8b 07 85 c0 
      
      Stack: [0x50c4c000,0x50ccd000),  sp=0x50ccba3c,  free space=510k
      Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
      V  [libjvm.so+0x402d4f]
      V  [libjvm.so+0x21611f]
      V  [libjvm.so+0x224e8d]
      V  [libjvm.so+0x4d8cbe]
      V  [libjvm.so+0x2136c7]
      V  [libjvm.so+0x1969ae]
      V  [libjvm.so+0x213962]
      V  [libjvm.so+0x51f8c4]
      V  [libjvm.so+0x51f5f6]
      V  [libjvm.so+0x51ec07]
      V  [libjvm.so+0x51ee75]
      V  [libjvm.so+0x51e9e0]
      V  [libjvm.so+0x43c008]
      C  [libpthread.so.0+0x573b]
      
      VM_Operation (0x46d410d0): generation collection for allocation, mode: safepoint, requested by thread 0x4b65bb20
      
      





      Other Threads:
      =>0x096d1948 VMThread [id=3312]
        0x096e45a0 WatcherThread [id=3320]
      
      VM state:at safepoint (normal execution)
      
      VM Mutex/Monitor currently owned by a thread:  ([mutex/lock_event])
      [0x096048f8/0x09604920] Threads_lock - owner thread: 0x096d1948
      [0x09604d48/0x09604d60] Heap_lock - owner thread: 0x4b65bb20
      
      Heap
       par new generation   total 235968K, used 0K [0x51250000, 0x61250000, 0x61250000)
        eden space 209792K,   0% used [0x51250000, 0x51250000, 0x5df30000)
        from space 26176K,   0% used [0x5f8c0000, 0x5f8c0000, 0x61250000)
        to   space 26176K,   0% used [0x5df30000, 0x5df30000, 0x5f8c0000)
       tenured generation   total 786432K, used 450926K [0x61250000, 0x91250000, 0x91250000)
         the space 786432K,  57% used [0x61250000, 0x7caabbb8, 0x7caabc00, 0x91250000)
       compacting perm gen  total 262144K, used 68650K [0x91250000, 0xa1250000, 0xb1250000)
         the space 262144K,  26% used [0x91250000, 0x9555a810, 0x9555aa00, 0xa1250000)
      No shared spaces configured.





      _VM Arguments:
      jvm_args: -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms1024m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m -XX:MinHeapFreeRatio=40 -XX:MaxHeapFreeRatio=70 -XX:NewRatio=3 -XX:MaxNewSize=512m -Dsun.rmi.dgc.server.gcInterval=3600000 -XX:+UseParNewGC -XX:+CMSPermGenSweepingEnabled -XX:+ClassUnloading -XX:+CMSClassUnloadingEnabled -XX:CompileThreshold=100 -XX:CompileThreshold=100 -XX:+PrintGCDetails -verbose:gc -Xloggc:/serwer/jvm -Djava.util.logging.config.file=/serwer/tomcat6/conf/logging.properties -Djava.endorsed.dirs=/serwer/tomcat6/endorsed -Dcatalina.base=/serwer/tomcat6 -Dcatalina.home=/serwer/tomcat6 -Djava.io.tmpdir=/serwer/tomcat6/temp
      java_command: org.apache.catalina.startup.Bootstrap start
      Launcher Type: SUN_STANDARD_
      
      Environment Variables:
      JAVA_HOME=/serwer/install/jdk1.5.0_22
      PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
      LD_LIBRARY_PATH=/serwer/install/jdk1.5.0_22/jre/lib/i386/server:/serwer/install/jdk1.5.0_22/jre/lib/i386:/serwer/install/jdk1.5.0_22/jre/../lib/i386
      SHELL=/bin/bash
      
      Signal Handlers:
      SIGSEGV: [libjvm.so+0x517630], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGBUS: [libjvm.so+0x517630], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGFPE: [libjvm.so+0x43a430], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGPIPE: [libjvm.so+0x43a430], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGILL: [libjvm.so+0x43a430], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGUSR1: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
      SIGUSR2: [libjvm.so+0x43c880], sa_mask[0]=0x00000000, sa_flags=0x10000004
      SIGHUP: [libjvm.so+0x43c2b0], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGINT: SIG_IGN, sa_mask[0]=0x00000000, sa_flags=0x00000000
      SIGQUIT: [libjvm.so+0x43c2b0], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      SIGTERM: [libjvm.so+0x43c2b0], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
      
      
      ---------------  S Y S T E M  ---------------
      
      OS:CentOS release 5.4 (Final)
      
      uname:Linux 2.6.18-164.9.1.el5PAE #1 SMP Tue Dec 15 21:41:47 EST 2009 i686
      libc:glibc 2.5 NPTL 2.5 
      rlimit: STACK 10240k, CORE 0k, NPROC 73728, NOFILE 1024, AS infinity
      load average:1.38 0.98 0.82
      
      CPU:total 4 (cores per cpu 4, threads per core 1) family 6 model 7 stepping 10, cmov, cx8, fxsr, mmx, sse, sse2
      
      Memory: 4k page, physical 4151668k(1011344k free), swap 1280k(1280k free)
      
      vm_info: Java HotSpot(TM) Server VM (1.5.0_22-b03) for linux-x86, built on Oct  9 2009 01:43:39 by java_re with gcc 3.2.1-7a (J2SE release)
      
      time: Mon Jan 25 18:04:14 2010
      elapsed time: 17257 seconds




      The question is: Can I run two applications on same tomcat with other Seam versions?
      Can you help me and tell me what crash my tomcat server?