6 Replies Latest reply on Sep 20, 2010 9:53 AM by Gabor Jakab

    Resteasy EAR - Could not find resource for relative

    Carey Foushee Newbie
      I am using the JBoss Developer Studio 2.1 and JBoss 4.2.3 and Seam 2.2.

      I have an EAR project made from the seam-gen called sbd.  I am read the Web Services in Chp. 24 and am following this howto:  http://www.seamframework.org/112129.lace and have discovered this post that had a similiar problem last year:  http://seamframework.org/103029.lace

      I've tried both the jaxrs/resteasy jars that come with seam 2.2 and the 1.2 jars directly from resteasy.  I put them in the WEB-INF/lib and then update the META-INF/MANIFEST.MF with them as well.

      When I startup jboss I see this in my log related to the resteasy loading:

      15:22:25,984 INFO  [Component] Component: org.jboss.seam.resteasy.application, scope: APPLICATION, type: JAVA_BEAN, class: org.jboss.seam.resteasy.Application
      15:22:25,984 INFO  [Component] Component: org.jboss.seam.resteasy.bootstrap, scope: APPLICATION, type: JAVA_BEAN, class: org.jboss.seam.resteasy.ResteasyBootstrap
      15:22:25,984 INFO  [Component] Component: org.jboss.seam.resteasy.resourceAdapter, scope: APPLICATION, type: JAVA_BEAN, class: org.jboss.seam.resteasy.ResteasyResourceAdapter
      ...
      15:22:26,484 INFO  [ResteasyBootstrap] bootstrapping JAX-RS application
      15:22:26,546 INFO  [ResteasyBootstrap] registering built-in RESTEasy providers

      Then I bring up browser and goto:  http://localhost:8080/sbd/seam/resource/rest/ping 
      I've tried it without the "rest" on the url but when I put the rest I get a little different 404 error:

      HTTP Status 404 - Could not find resource for relative : /ping of full path: http://localhost:8080/sbd/seam/resource/rest/ping

      Nothing shows up the console (log).